Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-133551

Command block activating without redstone (even though set to "Need redstone")

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 1.13-pre8, 20w13b
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
       

       
    • Confirmation Status:
      Confirmed
    • Category:
      (Unassigned)

      Description

      I am finding that command blocks that are not sending redstone signals are still activating adjacent command blocks that are set to "Need redstone".  

      Example command block A is set to "Impulse", "unconditional", "Needs Redstone".  It contains a "execute" command that reports pass or fail

      Command block B is set to "Impulse", "conditional", "Needs redstone".  The block behind it is A.   It contains just a "say" command. 

      When a redstone signal is sent to B from another source (not A), the execute command of A fires anyway.  Yet the "say command" when it fires is not sending out a redstone signal (no adjacent redstone lights up)

      A should not be firing but it is

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              MrChoke Adam
              Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                CHK: