Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-132135

Bad server side performance in 1.14

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 1.13-pre4, Minecraft 1.13-pre8, Minecraft 1.13-pre9, Minecraft 1.13, Minecraft 18w30a, Minecraft 18w30b, Minecraft 18w31a, Minecraft 1.13.1-pre1, Minecraft 1.13.1, Minecraft 1.13.2-pre1, Minecraft 1.13.2-pre2, Minecraft 1.13.2, Minecraft 18w48a, Minecraft 18w48b, Minecraft 18w49a, Minecraft 18w50a, Minecraft 19w12b, Minecraft 19w13b, Minecraft 19w14a, Minecraft 19w14b, Minecraft 1.14 Pre-Release 1, Minecraft 1.14 Pre-Release 2, Minecraft 1.14 Pre-Release 5, Minecraft 1.14, Minecraft 1.14.1, Minecraft 1.14.2 Pre-Release 1, Minecraft 1.14.2 Pre-Release 2, Minecraft 1.14.2, Minecraft 1.14.3, Minecraft 1.14.4 Pre-Release 1, Minecraft 1.14.4 Pre-Release 3, Minecraft 1.14.4 Pre-Release 4, Minecraft 1.14.4 Pre-Release 5
    • Fix Version/s: Minecraft 1.13-pre7
    • Environment:

      Windows 10, 7700k @ 5.0GHz, GTX 1080ti

    • Confirmation Status:
      Confirmed
    • Category:
      Performance

      Description

      As the snapshots for 1.13 have been getting released, occasionally I've been downloading my SMP world of over four years to test the performance on the snapshot. Every snapshot I've tested my existing world in has been fundamentally broken. 

      I just tried loading my world again with pre-release 4 and lo and behold, it's still insanely laggy for me. This is what my experience is like loading my 1.12.2 world into pre-release 4:

      • I get a 'loading world' screen immediately when I hit play. The percentage indicator goes anywhere from 8% to 64% before crashing. I have to do this 5-6 times just to get into the world. I look at the output log and there are errors all over the place.
      • When I do get in, it's a 90+ second wait. This loading screen is almost as if I'm generating a new world, which I'm not. I have a really large map file size at this point, and it's almost as if my entire world is trying to load at once.
      • Immediately when I load into the world, all I get is the sun/moon and sky. I have to log out and back in multiple times before chunks start loading.
      • When chunks do finally start loading, they load incredibly sporadically, rather than out from myself like it should. Random chunks just won't load period, no matter how many times I log out and back in. Light sources are all sorts of messed up and it's just unplayable.
      • There is some sort of 'lag' as if I'm on a server – I'll randomly start swimming 5-10 seconds after I leave the water and am in land. My elytra refuses to activate unless if I'm falling 30+ blocks. Blocks I break will immediately come back. Entities will lag all over the place, staying frozen for 3-5 second at a time before all teleporting at once.
      • Insane amounts of stuttering.

      I don't know what is going on but I'm starting to get worried for my world. I've been on this world since early 2014 and have never had any issues. I thought it might be a lack of Optifine causing these issues, but I have a very fast PC, and my 1.12.2 world works absolutely fine without Optifine. I haven't tried using MCEdit to prune my chunks or any sort of external tool to modify the terrain. I'm just trying to load my 1.12.2 world into the pre-release to test performance.

      At this point seeing all of the passing 'performance optimizations' in the changelogs for the snapshots is giving me a sense dread that my world is just not going to work moving forward.

       

      I can't attach my world, either. It's 300+ megabytes. If you would like me to share via Box or Google Drive, please let me know. 

      Thank you for the help. 

        Attachments

        1. 2018-06-26_22.05.03.png
          2018-06-26_22.05.03.png
          3.25 MB
        2. 2018-06-26-1.log
          16 kB
        3. 2018-06-26-7.log
          5 kB
        4. 2018-07-27_11.04.12.png
          2018-07-27_11.04.12.png
          495 kB
        5. 2018-07-27_15.14.52.png
          2018-07-27_15.14.52.png
          227 kB
        6. 2018-08-22_11.47.06.png
          2018-08-22_11.47.06.png
          307 kB
        7. 2018-08-22_11.49.44.png
          2018-08-22_11.49.44.png
          231 kB
        8. 2019-05-16_11.44.03.png
          2019-05-16_11.44.03.png
          2.51 MB
        9. 2019-05-27-4.log
          113 kB
        10. javaw_suuGljlf8N.png
          javaw_suuGljlf8N.png
          5 kB
        11. lag_Trim.mp4
          8.96 MB
        12. latest.log
          7 kB
        13. latest-after-optimization.log
          10 kB
        14. Loading Already Generated Chunks Lag Spikes.mp4
          8.88 MB
        15. Loading New Chunks Lag Spikes.mp4
          9.61 MB
        16. Pause Menu Lag Spike.mp4
          2.18 MB
        17. profile-results-2018-07-17_12.52.10.txt
          77 kB
        18. profile-results-2019-05-27_16.14.23.txt
          105 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                JFarf_Gl Jfarf_Gl
              • Votes:
                203 Vote for this issue
                Watchers:
                98 Start watching this issue

                Dates

                • Created:
                  Updated:
                  CHK: