Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-118269

Warning message "Command block chain tried to execute more than x steps!" appears even if less / no chain command blocks should run

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: Minecraft 1.12 Pre-Release 7, Minecraft 1.12.1, Minecraft 1.12.2, Minecraft 17w50a, Minecraft 18w03b, Minecraft 1.13.1, Minecraft 1.13.2, Minecraft 19w12b, Minecraft 19w13b, Minecraft 19w14a, Minecraft 19w14b
    • Fix Version/s: None
    • Confirmation Status:
      Confirmed
    • Category:
      (Unassigned)

      Description

      The bug

      The warning message "Command block chain tried to execute more than x steps!" appears in the log even when no or less command blocks should run.

      It looks like the message appears if there could be chain command block behind and additionally seems to count impulse and repeating command blocks as well.

      Note: Spelling fixes described in MC-118258 are applied.

      Commandblock chain tried to execure

      How to reproduce

      1. Set the gamerule maxCommandChainLength to 1
        /gamerule maxCommandChainLength 1
        
      2. Place an impulse command block and power it
      3. Look at the log
        → The warning message appeared, despite the fact that it should not have appeared
        → Also note that only one command block run and therefore no warning message should appear at all

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              marcono1234 [Mod] Marcono1234
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                CHK: