Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-109266

Repeaters and comparators don't update non-solid blocks in front of them

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 16w43a
    • Fix Version/s: Minecraft 16w44a
    • Labels:
      None
    • Confirmation Status:
      Unconfirmed

      Description

      Repeaters and comparators only give out block updates in case a solid block is in front of them.

      Powering a dropper/dispenser or piston like in picture 1, which was possible in all previous versions, is no longer possible, because the dropper/dispenser/piston doesn't receive the information, that it is powered.

      Powering only a single piston (picture 2) would be no longer possible without workarounds.

      Placing a block in front of the repeater wouldn't work, because it activates both pistons (picture 3)


      [Mojang] Grum (Erik Broes) added a comment - 2 hours ago - edited
      This happened when we made the observers not be able to power the airblock in front of them and thus being able to power the observer line with a gaps in it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                grum [Mojang] Grum (Erik Broes)
                Reporter:
                ilmango ilmango
              • Votes:
                18 Vote for this issue
                Watchers:
                50 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: