Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-108396

Taking armor off an armor stand but it still looks like the armor is still on there when it isn't

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 16w40a
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      OS: Windows 7 64-bit
      Java: Version 8 Update 101 (build 1.8.0_101-b13)
    • Confirmation Status:
      Unconfirmed

      Description

      I have a creative super-flat world with cheats enabled for structure designs. I am mostly experimenting with structure blocks.

      When I place an armor stand and put armor on it, then take it off again, it works as expected and the armor disappears from the armor stand and appears in the hotbar.
      As shown by images:
      2016-10-07_19.29.49.png
      2016-10-07_19.30.12.png

      When I use a structure block to duplicate the building, the duplicated version of the armor stand (duplicated with armor on the stand) does not work as expected. Taking armor off the stand puts it into my hotbar, but the armor is also still displayed on the armor stand.
      As shown by images:
      2016-10-07_19.30.37.png
      2016-10-07_19.30.48.png

      This happens regardless of what gamemode I am currently in.

      EDIT:
      Upon further investigation, this bug occurs from loading the armor with the [L] structure block and then loading it again in the exact same location. Even destroying the armor stand, the entity makes the sound and particles of being destroyed, yet it remains in place (and is affected by gravity).

      EDIT:
      Upon even more investigation, loading the armor stands with armor acts like this because it is placing the new armor stands on-top of the old one, therefore more than one armor stand is occupying the same space, yet only the most recently placed armor stand is accessible.

      What is expected that loading items with the [L] structure block would replace the entities and blocks already taking up the space.

      It is possible that entities such as the armor stand are not replaced intentionally and that this is completely expected behavior. I will investigate further by attempting to duplicate the problem with other entities such as NPC Villages or NPC sheep etc...

      EDIT:
      Confirmed that entities do not get replaced by the [L]structure block

        Attachments

        1. 2016-10-07_19.29.49.png
          2016-10-07_19.29.49.png
          293 kB
        2. 2016-10-07_19.30.12.png
          2016-10-07_19.30.12.png
          326 kB
        3. 2016-10-07_19.30.37.png
          2016-10-07_19.30.37.png
          293 kB
        4. 2016-10-07_19.30.48.png
          2016-10-07_19.30.48.png
          286 kB

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Strieker101 Christopher Rieker
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: