Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Awaiting Response
    • Affects Version/s: Minecraft 1.9.2, Minecraft 1.9.3 Pre-Release 3, Minecraft 1.9.3, Minecraft 1.9.4, Minecraft 1.10.2, Minecraft 16w41a
    • Fix Version/s: Minecraft 16w41a
    • Security Level: Minecraft - Public (Viewable by everyone)
    • Labels:
      None
    • Environment:

      Windows 10, Java 1.8

    • Confirmation Status:
      Unconfirmed

      Description

      Shield is supposed to show up to attacker:
      The shield should show up as blocking for both players.

      Shield only shows up for the attacker on the first hit:
      The person attacking after they hit the person defending once, can no longer see that the person defending is blocking. This means that it's a guessing game whether or not your opponent is actually blocking, because there's no visual feedback.

      Steps to Reproduce:
      1. Get a friend and have them hold a shield while you attack
      2. Watch as after you hit them their shield will be considered blocking but they will not be performing the block animation to you.

      As shown in the video, a fist will not make the shield disappear but any strike with a weapon will make the shield vanish from the attacker's view after the first strike.

      Thank you for your time.

      P.S. The sparks are from a combat plugin we have, but it is not the issue and we have tested this on multiple different servers including a vanilla LAN.

        Activity

        Hide
        Ih8MCsometimes added a comment -

        Hello, I'm just wondering if this ticket was skipped over by chance?

        Show
        Ih8MCsometimes added a comment - Hello, I'm just wondering if this ticket was skipped over by chance?
        Hide
        [Mod] Kumasasa added a comment -

        No, it's still open.

        Show
        [Mod] Kumasasa added a comment - No, it's still open.
        Hide
        Ih8MCsometimes added a comment -

        Sorry, there's just a lot of bugs and I didn't even see mine in the active list, was concerning me. Thank you for the reply!

        Show
        Ih8MCsometimes added a comment - Sorry, there's just a lot of bugs and I didn't even see mine in the active list, was concerning me. Thank you for the reply!
        Hide
        Jeffry Dallas added a comment -

        This bug is bothering me so much. This error makes shields useless.

        Show
        Jeffry Dallas added a comment - This bug is bothering me so much. This error makes shields useless.
        Hide
        Thomas Hall added a comment -

        This bug has not been patched. Tests in 16w41a continue to have desync on shield use.

        Show
        Thomas Hall added a comment - This bug has not been patched. Tests in 16w41a continue to have desync on shield use.
        Hide
        [Mojang] Grum (Erik Broes) added a comment -

        Is this still happening? We did changes in this area so this might be fixed.

        Show
        [Mojang] Grum (Erik Broes) added a comment - Is this still happening? We did changes in this area so this might be fixed.

          People

          • Assignee:
            [Mojang] Grum (Erik Broes)
            Reporter:
            Ih8MCsometimes
          • Votes:
            3 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: