Uploaded image for project: 'Minecraft: Java Edition'
  1. Minecraft: Java Edition
  2. MC-1005

Fresh install of 1.4.2 on fresh install of OSX 10.6.8 hangs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: Minecraft 1.4.2
    • Fix Version/s: Minecraft 1.4.6
    • Labels:
    • Environment:
    • Confirmation Status:
      Unconfirmed

      Description

      Minecraft will hang after being logging in and launched. The hang locks up the Minecraft process consuming 100% of a CPU, no keyboard or mouse movement possible, no screen updates happen.

      The lockup can happen a few seconds after generating a world and spawning, in the Options screen before entering a world, in the Select World screen, but always locks within a minute. The machine has happily run Minecraft for 6 months, this error started with 1.4.2 update. I have reformatted, reinstalled, and updated the Mac to try to remove all possible issues in the local configuration.

      I can switch away from Minecraft using Cmd-Tab and close the process.

      No log file is generated. The console has this, the GL ERROR appears when the hang happens:
      28/10/2012 11:12:00 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] 27 achievements
      28/10/2012 11:12:00 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] 208 recipes
      28/10/2012 11:12:00 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] Setting user: Prof_Purplex, 923613854198204245
      28/10/2012 11:12:00 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] LWJGL Version: 2.4.2
      28/10/2012 11:12:01 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] Starting up SoundSystem...
      28/10/2012 11:12:01 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] Initializing LWJGL OpenAL
      28/10/2012 11:12:01 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org)
      28/10/2012 11:12:01 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] OpenAL initialized.
      28/10/2012 11:12:02 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] ########## GL ERROR ##########
      28/10/2012 11:12:02 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] @ Pre render
      28/10/2012 11:12:02 [0x0-0x5e05e].com.Mojang Specifications.Minecraft.Minecraft[519] 1281: Invalid value

      I've tried other lwjgl versions, but they all give black screens. I've tried removing all /bin files, but that makes no difference.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                joyma Matthew Joyce
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: