XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: Minecraft 1.9
    • Fix Version/s: None
    • Labels:
    • Environment:
      Windows 10 Professional, Java update 74.
    • Confirmation Status:
      Unconfirmed

      Description

      Any mob_spawners being placed with /give will spawn the right mob for only the first time, after that it turn into a PIG spawner. mob spawners placed with /setblock command will just be a pig spawner. I am 99.99% sure I have used the right command.

      I have tried commands like...

      /setblock ~ ~ ~ minecraft:mob_spawner 0 replace {EntityId:Skeleton}
      /setblock ~ ~ ~ minecraft:mob_spawner 0 replace {BlockEntityTag:{SpawnData:{id:Zombie}}}
      
      /give @p minecraft:mob_spawner 1 0 {BlockEntityTag:{SpawnData:{id:Zombie}}}
      /give @p minecraft:mob_spawner 1 0 {EntityId:Zombie}

      They have created ERRORs

      However, I have tried to use

      /setblock ~ ~ ~ minecraft:mob_spawner 0 replace {SpawnData:{id:Zombie}}

      it seems to work for a while, but when I exit and re-enter the world, its a PIG spawner!

      Please Help!!

      P.S. Happy Easter!!!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                MiscyD MiscyD
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: